Ubuntuのフォルダ名を英語に変更

実際にはGPD WINのLinux化の続き、もうちょいメモ。

この辺りのことはまた新しいPCにLinux入れた時に忘れていそうなので、こまめに書いておくに限る。

 

タイトル通り、Ubuntuのインストール時にロケールで日本を選択すると、日本語になるのはいいけどホームのフォルダ名が全部日本語になってしまう。

これはコマンド一つで修正できることを最近知った。

 $ LANG=C xdg-user-dirs-gtk-update

これで各フォルダ名を変えるかどうか聞いてくる(英語で…)ウィンドウが開くので、変更する方を選択すれば自動で全部変わってくれる。

 

でも先日UbuntuにしたGPD WINでは、どうしても「ドキュメント」が日本語のまま残ってしまっていた。

もう一度上記のコマンドをやってみたんだが、二度目が起動しなかった。

なんでかなと思ってホームディレクトリをよく見たら、別に「Document」というフォルダが存在してる。

「ドキュメント」の方を開けてみたら、コマンドを書き写してた無題のテキストファイルが入ってた。

(もういらなかったので、これはフォルダごと削除した)

 

要するに、すでにフォルダに何か入っているとそれはそのままの名前で保留して、別に英語名のフォルダを作ってくれるらしい。

なのでファイルとフォルダの依存関係がややこしくなる前に、フォルダを英語にしておいたほうがいいということか。

今使っている他のUbuntuマシンでも困ってたので、もっと早く知りたかった。

 

さらに再起動した後、勝手にもう一度日本語に戻すかどうかという問い合わせが来てくれる。

いや、もういいから…。

日本語か英語に直した際、二度と表示しないようにチェックを入れておかないとこうなるだけ。

ユーザーに親切な造りと言って良いんだろうか。謎。

 

ちなみに結局日本語入力の設定は特にしてないんだけど、Linux mintを入れたGPD WINではちゃんと日本語入力もできるようになっていた。

入力時の切り替えショートカットは「Fcitx設定」というインストール済みのアプリから行える。

(最初GUI環境ではなかったので、そこだけインストールした)

今後使うことはないかもだけど、わかりやすくて良いと思う。

Sponsered Link

Ubuntuでapt upgradeのトラブル

GPD WINだけの問題じゃなさそうなので、他でもトラブルが起きたときのためにメモ。


Linux端末でsudo apt upgradeしていたところ、見慣れないエラー(のようなもの)が出た。

むちゃくちゃ行が多かったので、端折るとこんな感じ。

 エラー:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 bash amd64 4.4.18-2ubuntu1.2
  'archive.ubuntu.com' を解決できませんでした

  :

 (中略)

  :

 E: http://archive.ubuntu.com/ubuntu/pool/main/b/brltty/xbrlapi_5.5-4ubuntu2.0.1_amd64.deb の取得に失敗しました    'archive.ubuntu.com' を解決できませんでした
 E: いくつかのアーカイブを取得できません。apt-get update を実行するか --fix-missing オプションを付けて試してみてください。

 

謎なので、とりあえず記載されてる通りにsudo apt updateを実行したけど、同じようなエラーが出るだけ。

いったんapt autoremoveしてからapt upgradeしたりapt updateしてみてもダメ。同じようにエラーになってアップデートできない。

ただ、エラーの最後に

 E: 未解決の依存関係です。'apt --fix-broken install' を実行してみてください (または解法を明示してください)。

と出てくるので、素直にapt --fix-broken installも試してみた。

しかし、aptのコマンド一覧が出るだけで何も起こらない。


手詰まりかと思ったが、調べてみると意外と似たような症状が起きてる人がいた。
一例として、今回は以下のブログを参照させていただいた。

 https://blog.tizen.moe/entry/2016/02/13/202938

 

すでにエラーがいっぱい出てるのでaptitudeコマンドを使うのにどれを選べばいいのか不明だったが、とにかくエラーで最初に出たやつを選択しておけばいいか…と入力してみた。

 $ sudo aptitude install libgstreamer-gl1.0-0 

途中で出てくる問いにはyを入力。

一応は一通り終わったので、もう一度apt upgradeする。

 

 パッケージリストを読み込んでいます... 完了
 依存関係ツリーを作成しています                
 状態情報を読み取っています... 完了
 これらを直すためには 'apt --fix-broken install' を実行する必要があるかもしれません。
 以下のパッケージには満たせない依存関係があります:
  libgstreamer-gl1.0-0 : 依存: libgstreamer1.0-0 (>= 1.14.5) しかし、1.14.1-1~ubuntu18.04.1 はインストールされています
  libwebkit2gtk-4.0-37 : 依存: libjavascriptcoregtk-4.0-18 (= 2.26.2-0ubuntu0.18.04.1) しかし、2.20.1-1 はインストールされています
                        依存: libwoff1 (>= 1.0.0) しかし、インストールされていません
 E: 未解決の依存関係です。'apt --fix-broken install' を実行してみてください (または解法を明示してください)。

 

これでエラーがかなり減ったが、まだ出てる。
もしかしたらyesの時に入力する文字が小文字のyじゃなくて、大文字のYでないとダメだったのかなと思い、もう一度やってみる。

  $ sudo aptitude install libgstreamer-gl1.0-0 
今度は問いにYで全部答えた。

文字のおかげか単にもう一回やり直したためなのか、今度はエラーがなかった。(まあ大文字とかは関係ないと思うんで、二度目なのが良かったんじゃないかな)
これであらためてsudo apt upgradeしたところ大丈夫でした。

 

このコマンドについてまとめられているところを見つけたので、参考までに。

 https://www.garunimo.com/program/linux/aptitude.php

要するにソフトウェアをインストールするだけなのか。

でもまた同じようなエラーが出たら、試してみる価値はありそう。

Sponsered Link

UbuntuにVisual Studio Codeインストール

あんまりたいしたことはやってないけど、また後で検索するのも面倒なのでいつも通りやったことをメモしておく。

 

以前Windowsに入れたVisual Studio Codeを、Ubuntu環境にもインストールすることにした。

これがやることは別に難しくはないんだけど、なぜか方法がいろいろあってどれにするか悩んだ。

 

最初に参照しようとしていたのは以下。さすがQiita、なんでもある。

 https://qiita.com/yoshiyasu1111/items/e21a77ed68b52cb5f7c8

とても丁寧に、三通りの方法を説明していてわかりやすい。

さらに三通りもいらない人のためのリンクもある。

 https://qiita.com/yoshiyasu1111/items/e4db676e846897f8d554

さてどうしよう、と考えた末に、結局コマンドを入れる方法を使いませんでした。

 

最終的に参照したのは以下の方法でした。

 https://www.karelie.net/install-vscode-ubuntu/

ちょっと前の記事だけど、問題ないです。

公式のホームページ(https://code.visualstudio.com/docs/setup/linux)から、「 .deb package (64-bit)」をダウンロード。

ダウンロードフォルダにできたアイコンをダブルクリックしてインストールするという、Linuxらしからぬ方法を取りました。

当然起動は問題なく、そのまま日本語環境にしたりいろいろセッティング。

 

この方法だとバージョンアップとかパッケージの管理はどうなるのかとか、不安はあるけどそれも興味のうち。

(トラブルがあったらその時に調べればいいかなと思ってる)

せっかくWindowsっぽくインストールできたので、これで使ってみます。

Sponsered Link

Ubuntu 18.04でlockファイル関連の不具合

たいしたことをしようとしたわけじゃないんだが、Ubuntu 18.04の入ったPCにちょっとソフトを入れようとしたら、ロックがかかってできなくなっていた件。

またあるといけないので、恒例のやったことメモ。

 

sudo aptコマンドでソフトをインストールしようとしたら、

 

 E: ロック /var/lib/dpkg/lock-frontend が取得できませんでした - open (11: リソースが一時的に利用できません)
 E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?

 

と、出てきた。

その前に、そもそもupdateもupgradeもできなくなっていた。

最初に検索したところでは、autoremoveでなんとかなると書いてあったんだけど、やってみると同じエラーが出る。

なのでロックファイルを消してしまえということで、

 

 $ sudo rm /var/lib/apt/lists/lock
 $ sudo rm /var/lib/dpkg/lock

 $ sudo rm /var/lib/dpkg/lock-frontend

 

と、調べてわかる範囲で消せるものは消してみた。

これでどうかと思ったんだけど、結果は

 

 E: ロック /var/lib/dpkg/lock が取得できませんでした - open (11: リソースが一時的に利用できません)
 E: 管理用ディレクトリ (/var/lib/dpkg/) をロックできません。これを使う別のプロセスが動いていませんか?

 

と、出てきて結局インストールできなかった。

…なんか消さなくてもいいファイルまで消しちゃったようだ。

でもエラーが変わったので、これならできるかなと思い、試しにupgradeしてみると、

 

 $ sudo apt upgrade
 パッケージリストを読み込んでいます... 完了
 依存関係ツリーを作成しています                
 状態情報を読み取っています... 完了
 アップグレードパッケージを検出しています... 完了
 以下のパッケージが自動でインストールされましたが、もう必要とされていません:
   android-libext4-utils android-libselinux android-libsepol libf2fs0
   libllvm6.0 libllvm6.0:i386
 これを削除するには 'sudo apt autoremove' を利用してください。
 E: ロック /var/cache/apt/archives/lock が取得できませんでした - open (11: リソースが一時的に利用できません)
 E: ディレクトリ /var/cache/apt/archives/ をロックできません

 

となった。とりあえず、この時点でaptは使えそう。

なので改めてautoremove。

 

 $ sudo apt autoremove
 パッケージリストを読み込んでいます... 完了
 依存関係ツリーを作成しています                
 状態情報を読み取っています... 完了
 アップグレード: 0 個、新規インストール: 0 個、削除: 0 個、保留: 475 個。

 

これでエラーが出なくなった。

もう一度updateとupgradeを行い、さらにautoremoveもしたけど普通に完了。正常に戻った。

 

どうも前回のシャットダウン時になんかやらかしてたらしい。覚えがない。

全然インストールできなくなるので心配だったけど、あまり慌てなくても治せるエラーのようだ。

でもシャットダウン前に何かやっておかしくなったのはこれが初めてじゃないので、気を付けるようにはしたい…かな。

Sponsered Link

Ubuntu 18.04でYouTubeの動画ダウンロード

LaPotatoのUbuntu 18.04上で動画の検証をしたかったので、手っ取り早くYoutubeの動画をダウンロードした。

Ubuntu 18.04に限らずLinux上ならyoutube-dlというコマンドを使えば簡単なんだけど、インストールするのにちょい引っかかった。

というわけで、今後のためにメモ。

 

最初はシンプルにaptによるインストール。

 $ sudo apt install youtube-dl
その後、youtube-dltと落としたい動画のURLで一番高画質のものがダウンロードできるはず。
 $ youtube-dl  (YouTubeのURL)
しかし、
WARNING: unable to extract uploader nickname

と、
ERROR: Signature extraction failed: Traceback (most recent call last):

というエラーが出てダウンロードできない。

 

どうやら最新のyoutube-dlでないとダウンロードできないらしい。

YouTube側もダウンロードされないようにせっせと改善してるだろうから、それもそうだ。

アップデートにはオプションを付ければいいんだけど、
 $ sudo youtube-dl -U
It looks like you installed youtube-dl with a package manager, pip, setup.py or a tarball. Please use that to update.

うーん、これはバージョンアップできてないな。

試しに確認すると、
 $ youtube-dl --version
2016.02.22

…と、ずいぶん古いバージョンが入ってることがわかった。

 

エラーの文章で検索して見つけたブログから、

 http://blog.madadipouya.com/2016/02/27/how-to-update-youtube-dl-in-ubuntu/

簡単に言うと、直接youtube-dlをダウンロードして使えるようにするのが良いらしい。

 $ sudo wget https://yt-dl.org/downloads/latest/youtube-dl -O /usr/local/bin/youtube-dl

 $ sudo chmod a+x /usr/local/bin/youtube-dl

この後リブートが必要。

一応確認。

 $ sudo youtube-dl -U
youtube-dl is up-to-date (2018.09.18)

となって、最新のものがインストールできてた。

これでもう一度ダウンロードしてみると、今度は成功。

オプションで画質を選択したり音声のみダウンロードしたりできるらしいので、必要なときはhelpで確認してみるといいと思う。

 

他のところで検索してみたら、brewでインストールすると行けるとかあったのでインストールしちゃったりして、ここまでたどり着くのにまただいぶ遠回りした。

とはいえbrewも入ってて困ることはないので、放置してある。

 

ここまで頑張ってダウンロードしたけど、検証用に使いたかっただけだし容量がもったいないのでファイルの置き場に困る。

SBCを使ってる以上ストレージはSDカードなので、あんまり大きいファイルは置きたくないんだな。

なんだかんだでYoutubeを直接見た方が早いけど、インストールしておけは便利な時もあるかも(?)。

Sponsered Link